DSM6.2.3 Update2升级失败,提示文件可能毁损

在昨天安装了DSM6.2.3后,看到6.2.3有一个Update2的更新,于是我尝试更新,可是,当更新下载好开始安装时,更新程序却提示“无法更新文件,文件可能已经损毁”

2020/1/7更新:此方法似乎也适用于6.2.3-25426 Update 3

刚开始真的以为是文件损毁,重新下载了一遍更新文件,又手动从官网下载,都不行。于是怀疑是黑群晖问题

经过我不断的善用搜索引擎,终于成功的解决了这个问题,下面记录一下解决过程。

1.下载补丁文件

百度网盘:提取码am83

本地下载:网页链接

2.运行补丁

上传补丁到任意目录

右击,属性,获取文件位置

到设置–>计划任务新建一个任务,在任务设置的用户自定义脚本处输入(记得把/volume1/File/FixSynoboot.sh替换为你的任务

cp /volume1/File/FixSynoboot.sh /usr/local/etc/rc.d/FixSynoboot.sh
chmod 755 /usr/local/etc/rc.d/FixSynoboot.sh

保存后运行此任务,运行完成后即可删除此任务

3.再次更新

接着重启你的NAS,再次更新即可

4.删除残留脚本

不过,如果你有强迫症,你也可以在新建一个任务,写入以下代码

rm -rf /usr/local/etc/rc.d/FixSynoboot.sh

然后运行,即可删除刚才的脚本

版权声明:本站遵循CC BY-NC-SA 4.0版权协议,转载请附上原文地址、链接及本声明。
本文链接:美好的明天 - DSM6.2.3 Update2升级失败,提示文件可能毁损
THE END
分享
二维码
海报
DSM6.2.3 Update2升级失败,提示文件可能毁损
在昨天安装了DSM6.2.3后,看到6.2.3有一个Update2的更新,于是我尝试更新,可是,当更新下载好开始安装时,更新程序却提示“无法更新文件,文件可能已经损毁” 2……
<<上一篇
下一篇>>